개발도구/아이폰2012.03.06 14:06
  
페이스북 API 소스중 hackbook .. 빌드 하는 중에


Unsupported compiler ‘GCC 4.2′ selected for architecture ‘i386′
 

이러한 에러가 나오게 되었습니다.

해결 방법을 알려드립니다.
특히 이번 에러는 sdk5.0 이상일 경우에 발생할수 있습니다.

This can be caused by importing a project for a pre- iOS 5 SDK into a copy of xcode with iOS 5 SDK only.


먼저 Project -> Build Settings. 로 이동합니다.
검색에서  Build Options 뒤에 항목 Compiler for C/C++/Objective-C. 을 --> LLVM compiler 3.0

로 변경해줍니다.

그럼 이상없이 작동하는걸 발견합니다. 


Posted by 예배하는 프로그래머